#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^ FAIL "
Local $sString = " FAIL src/textutils.test.ts > startCase" & @CRLF & _
"AssertionError: expected 'Braised 1/2 Chicken' to deeply equal 'Baised 1/2 Chicken'" & @CRLF & _
" ❯ src/textutils.test.ts:8:28" & @CRLF & _
" 6| ["all lower case words", "All Lower Case Words"]," & @CRLF & _
" 7| ])("startCase", (input: string, expected: string) => {" & @CRLF & _
" 8| expect(startCase(input)).toEqual(expected)" & @CRLF & _
" | ^" & @CRLF & _
" 9| })" & @CRLF & _
" 10|" & @CRLF & _
"" & @CRLF & _
" - Expected "Baised 1/2 Chicken"" & @CRLF & _
" + Received "Braised 1/2 Chicken""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")