package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d*\S)`)
var str = `2y20w2d2h2m2s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}