$re = '/(\d*\S)/m';
$str = '2y20w2d2h2m2s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);