package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)CLIENT\..*[\,\)]`)
var str = `CLIENT.TEST,Toto.test,Test.Test,CLIENT.NOM,
Zozo.zaza,CLIENT.Truc,Watch.Machin,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}