$re = '/CLIENT\..*[\,\)]/m';
$str = 'CLIENT.TEST,Toto.test,Test.Test,CLIENT.NOM,
Zozo.zaza,CLIENT.Truc,Watch.Machin,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);