use strict;
my $str = 'Annotations of download.truelaunchbar.com
highlight [page 1]: True Launch Bar
highlight [page 8]: Creating shortcuts using Drag&Drop
highlight [page 9]: Creating plugins
highlight [page 11]: create a virtual folder, click on the “Browse…
highlight [page 12]: True Launch Bar supports all icon sizes. By default,
Highlight [133]: Click Options to select additional options for controlling which target items will be processed. To process all the files in subfolders of each target folder, mark the Search Nested Folders checkbox.
Underline [133]: You can also choose to process only text files or to process all file types. If you have graphics or other types of files in the target folders, you should restrict processing to only text files. This setting works in addition
Text [133]: testing';
my $regex = qr/^[^\]\n]+\]:[ \t]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";