// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\]\n]+\]:[ \t]+").unwrap();
let string = "Annotations of download.truelaunchbar.com
highlight [page 1]: True Launch Bar
highlight [page 8]: Creating shortcuts using Drag&Drop
highlight [page 9]: Creating plugins
highlight [page 11]: create a virtual folder, click on the “Browse…
highlight [page 12]: True Launch Bar supports all icon sizes. By default,
Highlight [133]: Click Options to select additional options for controlling which target items will be processed. To process all the files in subfolders of each target folder, mark the Search Nested Folders checkbox.
Underline [133]: You can also choose to process only text files or to process all file types. If you have graphics or other types of files in the target folders, you should restrict processing to only text files. This setting works in addition
Text [133]: testing";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}