$re = '/(?![0-9])
([\$\w][\w\d]+)+/mx';
$str = '= (cotimeataddressyears * 12) + cotimeataddressmonths2 * $somevar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);