re = /(?![0-9])
([\$\w][\w\d]+)+/mx
str = '= (cotimeataddressyears * 12) + cotimeataddressmonths2 * $somevar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end