$re = '/[ ]*([^: ]*)[^:]*$/m';
$str = 'XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ : ABCdef Service is Down
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ :ABCdef Service is Down
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ : ABCdef Service is Down
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ : ABCdef
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ :ABCdef
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ : ABCdef
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);