re = /[ ]*([^: ]*)[^:]*$/m
str = 'XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ : ABCdef Service is Down
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ :ABCdef Service is Down
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ : ABCdef Service is Down
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ : ABCdef
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ :ABCdef
XYZ Cloud : ABC : Windows : Non Prod : Silver : ABC123XYZ : ABCdef
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end