const regex = /Rep\d*[a|b|c|d|e]\d\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Rep\\d*[a|b|c|d|e]\\d\\d', 'gm')
const str = `Rep419a01 Καὶ ὁ Ἀδείμαντος ὑπολαβών, Τί οὖν, ἔφη, ὦ Σώκρατες,
Rep419a02 ἀπολογήσῃ, ἐάν τίς σε φῇ μὴ πάνυ τι εὐδαίμονας ποιεῖν
Rep419a03 τούτους τοὺς ἄνδρας, καὶ ταῦτα δι᾽ ἑαυτούς, ὧν ἔστι μὲν
Rep419a04 ἡ πόλις τῇ ἀληθείᾳ, οἱ δὲ μηδὲν ἀπολαύουσιν ἀγαθὸν τῆς
Rep419a05 πόλεως, οἷον ἄλλοι ἀγρούς τε κεκτημένοι καὶ οἰκίας οἰκοδομού–
Rep419a06 μενοι καλὰς καὶ μεγάλας, καὶ ταύταις πρέπουσαν κατασκευὴν
Rep419a07 κτώμενοι, καὶ θυσίας θεοῖς ἰδίας θύοντες, καὶ ξενοδοκοῦντες,
Rep419a08 καὶ δὴ καὶ ἃ νυνδὴ σὺ ἔλεγες, χρυσόν τε καὶ ἄργυρον κεκτη–
Rep419a09 μένοι καὶ πάντα ὅσα νομίζεται τοῖς μέλλουσιν μακαρίοις
Rep419a10 εἶναι; ἀλλ᾽ ἀτεχνῶς, φαίη ἄν, ὥσπερ ἐπίκουροι μισθωτοὶ ἐν
Rep420a01 τῇ πόλει φαίνονται καθῆσθαι οὐδὲν ἄλλο ἢ φρουροῦντες.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}