// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Rep\d*[a|b|c|d|e]\d\d").unwrap();
let string = "Rep419a01 Καὶ ὁ Ἀδείμαντος ὑπολαβών, Τί οὖν, ἔφη, ὦ Σώκρατες,
Rep419a02 ἀπολογήσῃ, ἐάν τίς σε φῇ μὴ πάνυ τι εὐδαίμονας ποιεῖν
Rep419a03 τούτους τοὺς ἄνδρας, καὶ ταῦτα δι᾽ ἑαυτούς, ὧν ἔστι μὲν
Rep419a04 ἡ πόλις τῇ ἀληθείᾳ, οἱ δὲ μηδὲν ἀπολαύουσιν ἀγαθὸν τῆς
Rep419a05 πόλεως, οἷον ἄλλοι ἀγρούς τε κεκτημένοι καὶ οἰκίας οἰκοδομού–
Rep419a06 μενοι καλὰς καὶ μεγάλας, καὶ ταύταις πρέπουσαν κατασκευὴν
Rep419a07 κτώμενοι, καὶ θυσίας θεοῖς ἰδίας θύοντες, καὶ ξενοδοκοῦντες,
Rep419a08 καὶ δὴ καὶ ἃ νυνδὴ σὺ ἔλεγες, χρυσόν τε καὶ ἄργυρον κεκτη–
Rep419a09 μένοι καὶ πάντα ὅσα νομίζεται τοῖς μέλλουσιν μακαρίοις
Rep419a10 εἶναι; ἀλλ᾽ ἀτεχνῶς, φαίη ἄν, ὥσπερ ἐπίκουροι μισθωτοὶ ἐν
Rep420a01 τῇ πόλει φαίνονται καθῆσθαι οὐδὲν ἄλλο ἢ φρουροῦντες.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}