using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^\[(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}.\d[^+]+\+\d{2}:\d{2})\]\s(?<channel>[^.]+).(?<level>[^:]+):\s(?<body>.*)$";
        string input = @"[2024-04-27T03:36:48.026983+00:00] report.DEBUG: Hello World!";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}