$re = '/^((?:[^:@\/#\?]+)(?:\:(?:[^:@\/#\?]*))?@){1}/mi';
$str = 'cnn.example.com&story=breaking_news@stillsquare.net/index.php?email=null@exchange.boeing.com%26method=post%26len
stillsquare.net/index.php?email=null@exchange.boeing.com%26method=post%26len
user:password@domain.com/path
user:@proxy.brew1.opendnstest.com/customBlockUserInfo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);