re = /^((?:[^:@\/#\?]+)(?:\:(?:[^:@\/#\?]*))?@){1}/mi
str = 'cnn.example.com&story=breaking_news@stillsquare.net/index.php?email=null@exchange.boeing.com%26method=post%26len
stillsquare.net/index.php?email=null@exchange.boeing.com%26method=post%26len
user:password@domain.com/path
user:@proxy.brew1.opendnstest.com/customBlockUserInfo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end