#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^| )(-?\d{1,2}(\.\d+)?(?=\s*,?\s*)[\s,]+-?\d{1,3}(\.\d+)?|\d{1,2}(\.\d+°|°(\d{1,2}(\.\d+'|'(\d{1,2}(\.\d+)?\")?))?)[NS](?=\s*,?\s*)[\s,]+\d{1,3}(\.\d+°|°(\d{1,2}(\.\d+'|'(\d{1,2}(\.\d+)?\")?))?)[EW])"
Local $sString = "73.180633 , -98.100802" & @CRLF & _
"" & @CRLF & _
"73°N 75°E" & @CRLF & _
"73.343°N 75.454°E" & @CRLF & _
"73°23'N 75°34'E" & @CRLF & _
"73°23.23'N 75°34.23'E" & @CRLF & _
"73°10'50.3"N 98°06'02.9"W" & @CRLF & _
"73°10'50.3"N,98°06'02.9"W" & @CRLF & _
"23°10'50.3"N 98°06'02.9"W"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")