$re = '/(^| )(-?\d{1,2}(\.\d+)?(?=\s*,?\s*)[\s,]+-?\d{1,3}(\.\d+)?|\d{1,2}(\.\d+°|°(\d{1,2}(\.\d+\'|\'(\d{1,2}(\.\d+)?\")?))?)[NS](?=\s*,?\s*)[\s,]+\d{1,3}(\.\d+°|°(\d{1,2}(\.\d+\'|\'(\d{1,2}(\.\d+)?\")?))?)[EW])/m';
$str = '73.180633 , -98.100802
73°N 75°E
73.343°N 75.454°E
73°23\'N 75°34\'E
73°23.23\'N 75°34.23\'E
73°10\'50.3"N 98°06\'02.9"W
73°10\'50.3"N,98°06\'02.9"W
23°10\'50.3"N 98°06\'02.9"W';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);