import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:((?:[-+]?\\d{1,2}[.]\\d+),\\s*(?:[-+]?\\d{1,3}[.]\\d+))|(\\d{1,3}°\\d{1,3}'\\d{1,3}\\.\\d\\\"[N|S]\\s\\d{1,3}°\\d{1,3}'\\d{1,3}\\.\\d\\\"[E|W]))";
final String string = "73.180633, -98.100802\n"
+ "73°10'50.3\"N 98°06'02.9\"W\n"
+ "36°10'13.6\"N 115°08'23.6\"W\n"
+ "115°10'13.6\"N 115°08'23.6\"W";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}