re = /(?:((?:[-+]?\d{1,2}[.]\d+),\s*(?:[-+]?\d{1,3}[.]\d+))|(\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[N|S]\s\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[E|W]))/m
str = '73.180633, -98.100802
73°10\'50.3"N 98°06\'02.9"W
36°10\'13.6"N 115°08\'23.6"W
115°10\'13.6"N 115°08\'23.6"W'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end