package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bX\b`)
var str = `X测试一Q测试二XQ测试三`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}