$re = '/\bX\b/a';
$str = 'X测试一Q测试二XQ测试三';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);