$re = '/<img.*?title="([^"]+)"\s*src="([^"]+)"/';
$str = '<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);