import Foundation
let pattern = #"<img.*?title="([^"]+)"\s*src="([^"]+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写<img alt="大气超级品牌日活动宣传海报" title="大气超级品牌日活动宣传海报" src="http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226" width="226" height="546" /> 请问只取title和src 应该怎么写"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)