import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:https?://)?(?:(?i:[a-z]+\\.)+)[^\\s,]+\\b";
final String string = "This is just a post to test regex for extracting URL http://google.com, https://www.youtube.com/watch?v=dlw32af https://instagram.com/oscar/ en.wikipedia.org\n"
+ "Even works for www.wikipedia.de, https://de.wikipedia.org/wiki/Wikipedia:Hauptseite or any other https://en.wikipedia.org/wiki/Regular_expression url. Even comma separated www.url1.com,www.url2.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}