re = /\b(?:https?:\/\/)?(?:(?i:[a-z]+\.)+)[^\s,]+\b/
str = 'This is just a post to test regex for extracting URL http://google.com, https://www.youtube.com/watch?v=dlw32af https://instagram.com/oscar/ en.wikipedia.org
Even works for www.wikipedia.de, https://de.wikipedia.org/wiki/Wikipedia:Hauptseite or any other https://en.wikipedia.org/wiki/Regular_expression url. Even comma separated www.url1.com,www.url2.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end