# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)(?:\.s3[-.].*)$/$1/gmi;t' <<< "bucket-name.s3.us-west-2.amazonaws.com
bucket.name.s3.us-west-2.amazonaws.com
bucket-name.s3-us-west-2.amazonaws.com
bucket.name.s3-us-west-2.amazonaws.com
bucket-name.s3.amazonaws.com
bucket.name.s3.amazonaws.com"