re = /^(.+)(?:\.s3[-.].*)$/mi
str = 'bucket-name.s3.us-west-2.amazonaws.com
bucket.name.s3.us-west-2.amazonaws.com
bucket-name.s3-us-west-2.amazonaws.com
bucket.name.s3-us-west-2.amazonaws.com
bucket-name.s3.amazonaws.com
bucket.name.s3.amazonaws.com'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result