// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$").unwrap();
let string = "MMMMDDYY
MDYY
YYYYDDMM
MDYY
DDDDDYYYMM
OODDYYMM
YYDDMMPPPP";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}