$re = '/^(?=.{18})(?:[a-zA-Z]+\d|\d+[a-zA-Z])[a-zA-Z\d]*$/m';
$str = '1Z83E0590391137855
55t5555t5t5tttt5t5555tttttttgggggggsss
1st
2nd
3rd
4th
5th';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);