import re
regex = re.compile(r"^(?=.{18})(?:[a-zA-Z]+\d|\d+[a-zA-Z])[a-zA-Z\d]*$", flags=re.MULTILINE)
test_str = ("1Z83E0590391137855\n"
"55t5555t5t5tttt5t5555tttttttgggggggsss\n"
"1st\n"
"2nd\n"
"3rd\n"
"4th\n"
"5th")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")