package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|[^"'])((?:ftp|https?|file):\/\/\S+)(?:\b|$)`)
var str = ` #1: https://some.link`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}