re = /(?:^|[^"'])((?:ftp|https?|file):\/\/\S+)(?:\b|$)/m
str = ' #1: https://some.link'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end