#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![.,]?$)\d*[,.]?(?:\d{1,2})?$"
Local $sString = "8.55" & @CRLF & _
"8." & @CRLF & _
"8.,5" & @CRLF & _
",,5" & @CRLF & _
",5" & @CRLF & _
",8" & @CRLF & _
"888" & @CRLF & _
"." & @CRLF & _
"letter"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")