import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![.,]?$)\\d*[,.]?(?:\\d{1,2})?$";
final String string = "8.55\n"
+ "8.\n"
+ "8.,5\n"
+ ",,5\n"
+ ",5\n"
+ ",8\n"
+ "888\n"
+ ".\n"
+ "letter";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}