import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^\\(\\[\\{〈【〔([]+|(?:(\\((?>[^()]++|(?1))*\\))|(\\{(?>[^\\{\\}]++|(?2))*\\})|(\\[(?>[^\\[\\]]++|(?3))*\\])|(〈(?>[^〈〉]++|(?4))*〉)|(【(?>[^【】]++|(?5))*】)|(〔(?>[^〔〕]++|(?6))*〕)|(((?>[^()]++|(?7))*))|([(?>[^[]]++|(?8))*]))(*SKIP)(*FAIL)|[\\S\\s])";
final String string = "hello (hi that [is] so cool) awesome 〈yeah〉 one \n"
+ "【yeah】 two 〔yeah〕 three (yeah) four [yeah] five \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}