re = /(?:[^\(\[{〈【〔([]+|(?:(\((?>[^()]++|(?1))*\))|({(?>[^{}]++|(?2))*})|(\[(?>[^\[\]]++|(?3))*\])|(〈(?>[^〈〉]++|(?4))*〉)|(【(?>[^【】]++|(?5))*】)|(〔(?>[^〔〕]++|(?6))*〕)|(((?>[^()]++|(?7))*))|([(?>[^[]]++|(?8))*]))(*SKIP)(*FAIL)|[\S\s])/
str = 'hello (hi that [is] so cool) awesome 〈yeah〉 one
【yeah】 two 〔yeah〕 three (yeah) four [yeah] five
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end