const regex = new RegExp('^((?:(https?://|/).[^/]+)+)$', 'gm')
const str = `/admissions/dual/index.html
/admissions/dual/index.html/
/apply/index.html/
///admissions/index.html
http://www.google.com
https://www.google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}