re = /^((?:(https?:\/\/|\/).[^\/]+)+)$/m
str = '/admissions/dual/index.html
/admissions/dual/index.html/
/apply/index.html/
///admissions/index.html
http://www.google.com
https://www.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end