$re = '/AX[BCD][EFG](\d[A-Z\d]{4}|[A-Z\d]\d[A-Z\d]{3}|[A-Z\d]{2}\d[A-Z\d]{2}|[A-Z\d]{3}\d[A-Z\d]|[A-Z\d]{4}\d)/m';
$str = 'AXBE1BCDE
AXBEA2CDE
AXBEAB3DE
AXBEABC4E
AXBEABCD5
AXBE1BCD5
AXBE12345
AXBEABCDE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);