import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\G)(?<variable>\\w+)\\s*(?<operator>>?=)\\s*(?<value>\\w+)\\s*(?:(?<conjunct>and|or) )?";
final String string = "situation >= 10 or situationB = off and situationC = on\n\n"
+ "situation = on";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}