re = /(?:^|\G)(?<variable>\w+)\s*(?<operator>>?=)\s*(?<value>\w+)\s*(?:(?<conjunct>and|or) )?/m
str = 'situation >= 10 or situationB = off and situationC = on
situation = on'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end