using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:,\d+)?(?: g| oz)? (.*)";
string input = @"12,2 g this is fully random
89 g random string 2
0,6 oz random stuff
1 really random stuff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}