re = /\d+(?:,\d+)?(?: g| oz)? (.*)/m
str = '12,2 g this is fully random
89 g random string 2
0,6 oz random stuff
1 really random stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end