re = /^(?!(\=|\<))(.*?):(.*?);/m
str = 'div {
color: red;
background-color: red;
}
<div style=\'color: red; background-color: black\'>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end