package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^,\n]+),([^,\n]+)$`)
var str = `section1,section2,section3
,section2,section3
section2,section3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}