re = /([^,\n]+),([^,\n]+)$/m
str = 'section1,section2,section3
,section2,section3
section2,section3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end