#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z0-9]{8}_\d{4}$"
Local $sString = "ED1234ND_2345" & @CRLF & _
"YD1COP1Z_3456" & @CRLF & _
"abc_123" & @CRLF & _
"AAAABBBB_55559" & @CRLF & _
"11111111_1111" & @CRLF & _
"11111111_11111" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")