import re
regex = re.compile(r"[A-Z0-9]{8}_\d{4}$", flags=re.MULTILINE)
test_str = ("ED1234ND_2345\n"
"YD1COP1Z_3456\n"
"abc_123\n"
"AAAABBBB_55559\n"
"11111111_1111\n"
"11111111_11111\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")