#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)192\.168\.(1?[0-9][0-9]?|2[0-4][0-9]|25[0-5])\.([2-9]|[1-9][0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-4])[[:space:]]"
Local $sString = "eth0 Link encap:Ethernet HWaddr 09:00:12:90:e3:e5 " & @CRLF & _
" inet addr:192.168.1.29 Bcast:192.168.1.255 Mask:255.255.255.0" & @CRLF & _
" inet6 addr: fe80::a00:27ff:fe70:e3f5/64 Scope:Link" & @CRLF & _
" UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1" & @CRLF & _
" RX packets:54071 errors:1 dropped:0 overruns:0 frame:0" & @CRLF & _
" TX packets:48515 errors:0 dropped:0 overruns:0 carrier:0" & @CRLF & _
" collisions:0 txqueuelen:1000 " & @CRLF & _
" RX bytes:22009423 (20.9 MiB) TX bytes:25690847 (24.5 MiB)" & @CRLF & _
" Interrupt:10 Base address:0xd020 " & @CRLF & _
"lo Link encap:Local Loopback " & @CRLF & _
" inet addr:127.0.0.1 Mask:255.0.0.0" & @CRLF & _
" inet6 addr: ::1/128 Scope:Host" & @CRLF & _
" UP LOOPBACK RUNNING MTU:16436 Metric:1" & @CRLF & _
" RX packets:83 errors:0 dropped:0 overruns:0 frame:0" & @CRLF & _
" TX packets:83 errors:0 dropped:0 overruns:0 carrier:0" & @CRLF & _
" collisions:0 txqueuelen:0 " & @CRLF & _
" RX bytes:7766 (7.5 KiB) TX bytes:7766 (7.5 KiB)" & @CRLF & _
"wlan0 Link encap:Ethernet HWaddr 58:a2:c2:93:27:36 " & @CRLF & _
" inet addr:192.168.1.64 Bcast:192.168.2.255 Mask:255.255.255.0" & @CRLF & _
" inet6 addr: fe80::6aa3:c4ff:fe93:4746/64 Scope:Link" & @CRLF & _
" UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1" & @CRLF & _
" RX packets:436968 errors:0 dropped:0 overruns:0 frame:0" & @CRLF & _
" TX packets:364103 errors:0 dropped:0 overruns:0 carrier:0" & @CRLF & _
" collisions:0 txqueuelen:1000 " & @CRLF & _
" RX bytes:115886055 (110.5 MiB) TX bytes:83286188 (79.4 MiB)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")